CWE-129 - Improper Validation of Array Index

The product uses untrusted input when calculating or using an array index, but the product does not validate or incorrectly validates the index to ensure the index references a valid position within the array.

Related CVE(s) 70 CVE-2019-10499 CVSS 7.2 CVE-2019-13418 CVSS 5 CVE-2019-2346 CVSS 7.2 CVE-2019-2326 CVSS 7.2 CVE-2018-17478 CVSS 6.8 CVE-2018-5903 CVSS 7.2 CVE-2018-5883 CVSS 7.2 CVE-2018-13902 CVSS 5 CVE-2018-11927 CVSS 7.2 CVE-2017-18274 CVSS 7.2 CVE-2019-5666 CVSS 7.2 CVE-2019-9162 CVSS 4.6 CVE-2018-13913 CVSS 4.6 CVE-2018-11948 CVSS 4.9 CVE-2018-11899 CVSS 4.6 CVE-2019-1000016 CVSS 4.3 CVE-2018-11288 CVSS 7.2 CVE-2018-4210 CVSS 6.8 CVE-2018-11996 CVSS 7.2 CVE-2018-5914 CVSS 7.2 CVE-2017-18309 CVSS 6.6 CVE-2018-17848 CVSS 5 CVE-2018-11269 CVSS 7.2 CVE-2018-11268 CVSS 7.2 CVE-2018-11267 CVSS 7.2 CVE-2018-11902 CVSS 7.2 CVE-2018-11891 CVSS 8.3 CVE-2018-11883 CVSS 7.2 CVE-2018-11827 CVSS 7.2 CVE-2018-11299 CVSS 7.2 CVE-2018-16648 CVSS 4.3 CVE-2018-11263 CVSS 5.8 CVE-2018-13302 CVSS 6.8 CVE-2018-5851 CVSS 4.6 CVE-2018-3576 CVSS 4.6 CVE-2017-15857 CVSS 4.6 CVE-2017-5445 CVSS 5 CVE-2018-7406 CVSS 6.8 CVE-2017-15855 CVSS 4.6 CVE-2016-10454 CVSS 10 CVE-2014-9990 CVSS 10 CVE-2014-9989 CVSS 10 CVE-2014-10048 CVSS 10 CVE-2014-10044 CVSS 5 CVE-2017-15830 CVSS 4.6 CVE-2017-14889 CVSS 4.6 CVE-2017-15861 CVSS 7.2 CVE-2017-16410 CVSS 9.3 CVE-2017-16391 CVSS 9.3 CVE-2017-8172 CVSS 7.1 CVE-2017-16899 CVSS 5.8 CVE-2017-0836 CVSS 9.3 CVE-2017-11292 CVSS 6.5 CVE-2017-8251 CVSS 6.8 CVE-2015-8316 CVSS 4.3 CVE-2017-0805 CVSS 9.3 CVE-2017-10663 CVSS 7.2 CVE-2016-10386 CVSS 10 CVE-2017-0737 CVSS 6.8 CVE-2017-0716 CVSS 9.3 CVE-2017-8797 CVSS 7.8 CVE-2014-9948 CVSS 9.3 CVE-2017-0347 CVSS 7.2 CVE-2017-0345 CVSS 7.2 CVE-2017-7228 CVSS 7.2 CVE-2016-9053 CVSS 7.5 CVE-2017-0322 CVSS 7.2 CVE-2016-8816 CVSS 7.2 CVE-2016-8815 CVSS 7.2 CVE-2014-6317 CVSS 7.1