2009-04-24 16:30:00 2017-09-29 03:34:22

SQL injection vulnerability in usersettings.php in e107 0.7.15 and earlier, when "Extended User Fields" is enabled and magic_quotes_gpc is disabled, allows remote attackers to execute arbitrary SQL commands via the hide parameter, a different vector than CVE-2005-4224 and CVE-2008-5320.

Vector

NETWORK

Complexity

HIGH

Authentication

NONE

Confidentiality

PARTIAL

Integrity

PARTIAL

Availability

PARTIAL
E107 E107 0.547 beta (not an official CPE) E107 E107 0.554 (not an official CPE) E107 E107 0.615 (not an official CPE) E107 E107 0.6 14 (not an official CPE) E107 E107 0.613 (not an official CPE) E107 E107 0.616 (not an official CPE) E107 E107 5.1 (not an official CPE) E107 E107 5.4 beta3 (not an official CPE) E107 E107 5.2 (not an official CPE) E107 E107 0.617 (not an official CPE) E107 E107 5.4 beta1 (not an official CPE) E107 E107 0.6172 (not an official CPE) E107 E107 0.6175 (not an official CPE) E107 E107 0.548 beta (not an official CPE) E107 E107 0.6173 (not an official CPE) E107 E107 0.611 (not an official CPE) E107 E107 0.6 13 (not an official CPE) E107 E107 0.549 beta (not an official CPE) E107 E107 0.614 (not an official CPE) E107 E107 0.6174 (not an official CPE) E107 E107 0.6 15 (not an official CPE) E107 E107 5.4 beta6 (not an official CPE) E107 E107 0.612 (not an official CPE) E107 E107 0.6 12 (not an official CPE) E107 E107 5.4 beta4 (not an official CPE) E107 E107 5.4 beta5 (not an official CPE) E107 E107 0.6 11 (not an official CPE) E107 E107 0.615a (not an official CPE) E107 E107 0.6 10 (not an official CPE) e107 0.7.1 E107 E107 0.604 (not an official CPE) E107 E107 0.554 beta (not an official CPE) e107 0.7.4 E107 E107 0.607 (not an official CPE) E107 E107 5.04 (not an official CPE) E107 E107 0.602 (not an official CPE) e107 0.7.2 E107 E107 0.605 (not an official CPE) E107 E107 5.3 beta (not an official CPE) e107 0.7.3 E107 E107 0.606 (not an official CPE) E107 E107 5.05 (not an official CPE) e107 1.0.1 e107 0.7.9 e107 0.7.7 E107 E107 0.600 (not an official CPE) E107 E107 0.603 (not an official CPE) E107 E107 0.601 (not an official CPE) E107 E107 0.553 beta (not an official CPE) e107 0.7.5 E107 E107 0.608 (not an official CPE) e107 0.7.8 E107 E107 0.6171 (not an official CPE) e107 0.7.6 E107 E107 0.609 (not an official CPE) E107 E107 0.555 beta (not an official CPE) E107 E107 0.610 (not an official CPE) E107 E107 5.3 beta2 (not an official CPE) e107 0.7 E107 E107 0.552 beta (not an official CPE) E107 E107 0.551 beta (not an official CPE) E107 E107 5.21 (not an official CPE) E107 E107 0.545 (not an official CPE) e107 0.7.10 e107 0.7.13 e107 0.7.11 E107 E107 0.6 15a (not an official CPE)
Advisory Patch Confirmed Link
8495
34614
e107-hide-sql-injection(49981)